Feng Forum

Support => Installation problems => : joost April 02, 2009, 06:01:01 PM

: can't upload or create documents
: joost April 02, 2009, 06:01:01 PM
I have just done a new installation and everything went fine (1.3.1). However, I cannot upload any documents: Error Failed to import file 'tmp/.......' to the file repository (unique file ID: cb..............)

I am saving to disk, not to database. De upload directory is CHmodded. On the same server for a different domain OpenGoo is working fine, but that has been installed and upgraded from version 1.1

Could there be a problem with a complete clean installation?

The strange thing is, in my tmp directory some directories are made that I cannot remove anymore.

If I use the database system as file storage things work as expected, but I prefer to use the file system.

Any idea's?

: Re: can't upload or create documents
: Eichi April 05, 2009, 06:45:54 AM
Hey Guys,

I have pretty much the same problem. When I try to create a document it says "an error occurred...". The document is shown in "Documents" but I can't open it ("invalid file - there are no revisions..."). It's the same with checking my E-Mails ("Failed to create folder...."). I thought it's because of no CHMOD but "upload" is 777. There are also some folders in "upload" so it seems as if they CAN be created.

The problem doesn't occurr when using the database storage system.
: Re: can't upload or create documents
: Eichi April 13, 2009, 05:24:30 AM

Nobody an idea to fix this?
: Re: can't upload or create documents
: FrankDK April 16, 2009, 03:50:23 AM
I have the same problem and as you said, it can be solved by just using db and not files for storing documents.
I am not sure what the advantages or disadvantages are of using one or the other system, but as long as db is the only one I can use I am left with no choice really. But it would be nice to know how to solve this problem.
My theory (and I am a newbie here, so bear with me) is that it is some security settings on my site that is causing this. I have only limited control of these myself so if that is the problem I am not sure it can be solved.
: Re: can't upload or create documents
: sosamv July 23, 2009, 11:54:12 AM
I'm having the same issue, anyone please?????'
: Re: can't upload or create documents
: ignacio August 06, 2009, 12:54:36 PM
You can try making the web server's user (apache or www-data) the owner of all files and folders in your installation. E.g.:

chown -R apache:apache /path/to/installation
: Re: can't upload or create documents
: kgarnett August 19, 2009, 12:04:09 PM
I installed it on a windows 2003 platform and I have the same problems with the documents as well as sending and receiving emails.  It's not able to write to the upload folder. 

basically, the message I'm getting is "Cannot create folder

Noticing the slashes and backslashes is quite confusing sometimes.