Feng Forum

Other Topics => General Discussion => : gylf October 06, 2008, 05:30:19 PM

: SSL/TLS support (gmail) fix
: gylf October 06, 2008, 05:30:19 PM
Gmail requires SSL/TLS support to work properly and I am a faithful Gmail user.  I noticed a few other on here are as well.  So here is a fix to get Gmail (or another encrypted mail server) working with OpenGoo:

Download and install Stunnel (http://www.stunnel.org/)
It is a free program which will sit on your computer and download your email on command.  It supports SSL/TLS. 
Now edit your configuration file to look something like:

; Use it for client mode
client = yes

; Service-level configuration

[pop3s]
accept  = 110   
connect = pop.gmail.com:995

[ssmtp]
accept  = 25
connect = smtp.gmail.com:465

Now in OpenGoo put in your full email address for username and your password.  Set your Pop3 server to 127.0.0.1 and your smtp server to 127.0.0.1 with port 25.

It should now work!
: Re: SSL/TLS support (gmail) fix
: conrado October 06, 2008, 05:46:05 PM
Thank you!

Will definitely take a look at this.
: Re: SSL/TLS support (gmail) fix
: cabeza October 07, 2008, 09:33:14 AM
Thank you gylf
: Re: SSL/TLS support (gmail) fix
: lega November 11, 2008, 11:11:32 AM
Gmail requires SSL/TLS support to work properly and I am a faithful Gmail user.  I noticed a few other on here are as well.  So here is a fix to get Gmail (or another encrypted mail server) working with OpenGoo:

Download and install Stunnel (http://www.stunnel.org/)
It is a free program which will sit on your computer and download your email on command.  It supports SSL/TLS. 
Now edit your configuration file to look something like:

; Use it for client mode
client = yes

; Service-level configuration

[pop3s]
accept  = 110   
connect = pop.gmail.com:995

[ssmtp]
accept  = 25
connect = smtp.gmail.com:465

Now in OpenGoo put in your full email address for username and your password.  Set your Pop3 server to 127.0.0.1 and your smtp server to 127.0.0.1 with port 25.

It should now work!

Hi! I just discovered OpenGoo and it feels write :)
However I have problems with setting up my Gmail
I folowed your Instructions but nada :(

I have to say that I use bluehost, and I uploaded the file on the ~/public_html directory and opengoo is at ~/public_html/opengoo

In the same time i cant folow the 4th step of the instructions
4. Add stunnel invocation to your system's startup files.
   For SysV-compatible init you can use stunnel.init script.

     or

   Modify /etc/services and /etc/inetd.conf, restart inetd (inetd mode).

   See the manual for details.


Since I dont have access on this directories!
any suggestions?

Thanks in advance :)
: Re: SSL/TLS support (gmail) fix
: ignacio November 11, 2008, 12:57:30 PM
Another workaround until we support SSL/TLS is to setup Gmail to forward all your email to another email account that supports POP3 without SSL (in your case, a bluehost email account).

It's far from ideal and you won't be able to retrieve your previous email, but it is better than nothing I guess...
: Re: SSL/TLS support (gmail) fix
: lega November 12, 2008, 04:14:58 AM
Well thanks on this! thats what I'll do!
: Re: SSL/TLS support (gmail) fix
: jgramosli February 04, 2009, 11:23:10 AM
Has anyone managed top get this working with the 1.2 rc1?

I've got my other email accounts working, but not with Gmail yet.  Just seems to do nothing, how the hell do you debug this system? Where are the logs kept?
: Re: SSL/TLS support (gmail) fix
: ignacio February 05, 2009, 09:25:17 AM
You have to set DEBUG to true in 'config/config.php'. There's a log in 'cache/log.php'.
: Re: SSL/TLS support (gmail) fix
: garoo March 08, 2010, 06:46:34 PM
Hi fellas!
Using mandriva and have same problem with the gmail ssl.
Is anybody solve this problem with linux?
: Re: SSL/TLS support (gmail) fix
: Boxerworks August 20, 2010, 12:19:33 PM
Cannot connect to my imap account on Google Apps.  So, I turned on debug as suggested above and here is the list of log messages from just now:
-------------------------------------------------------------------------------

Session "default" started at 2010-08-20T13:34:08+0000
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://smtp.gmail.com:587 (Connection refused) in '/home/motorrad/public_html/office/library/swift/lib/Swift/Connection/SMTP.php' on line 149 (error code: 2)
Time since start: 0.65101003646851 seconds
-------------------------------------------------------------------------------

Session "default" started at 2010-08-20T15:00:16+0000
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://imap.googlemail.com:993 (Connection refused) in '/home/motorrad/public_html/office/library/PEAR/Net/Socket.php' on line 138 (error code: 2)
Time since start: 0.39326596260071 seconds
-------------------------------------------------------------------------------

Session "default" started at 2010-08-20T15:16:28+0000
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://imap.googlemail.com:993 (Connection refused) in '/home/motorrad/public_html/office/library/PEAR/Net/Socket.php' on line 138 (error code: 2)
Time since start: 0.16923689842224 seconds


Can someone please point me in the right direction as to how to fix this?
: Re: SSL/TLS support (gmail) fix
: chumby September 08, 2010, 03:48:53 AM
Hi,

Has anyone found a definate fix to this.  I just cant get GMail working - can not send mail.

The message comes up when I try to send an email:

ERROR: The server does not support SSL.

I have IMAP enabled in gmail and the right settings appear to be self populating.  I am using the current version of feng 1.7

Please help,

Thanks
Chumby
: Re: SSL/TLS support (gmail) fix
: franponce87 September 08, 2010, 12:54:46 PM
Boxerworks, which FO version are you using?

Chumby, what settings are you using? For gmail accounts, the IMAP port is 993 and the SMTP is 465, and it uses SSL authentication.
: Re: SSL/TLS support (gmail) fix
: chumby September 08, 2010, 06:13:58 PM
Thanks Fran...

Yes I am using those settings.  Gmail fills them in automatically when I start to set up the account.

When I check ail, like 10 emails come in and thats it.  When I go to send email it comes up with the server SSL error.

Haven't been able to find anything at all to help...

Apprecite the help.

Cheers
Martin
: Re: SSL/TLS support (gmail) fix
: franponce87 September 09, 2010, 12:10:45 AM
No problem at all. By the way, you download only 10 emails every time you check your email, because you haven't changed that default value at the administration panel, which happens to be 10. If you want to download EVERY single email you have in that account, you should download your emails through the Cron (read page 2 and 3 here (http://forums.fengoffice.com/index.php?topic=4574.0) for more info).

About the SSL server error when sending the emails, check your email account configuration, at the outgoing part, if it is marked as SSL too, and the authentication being the same as incoming emails.

Greetings!
: Re: SSL/TLS support (gmail) fix
: chumby September 09, 2010, 12:23:22 AM
Yes SMTP is set to SSL as well... my settings in SMTP are:

SMTP Server - stmp.gmail.com
SMTP Server Port - 465
SMTP Server Auth - Use incoming
Secure Connection - SSL

Does that help?

Also where is the defalt set to 10 for emails?  I cannot see that in my admin panel.

Thanks
Martin
: Re: SSL/TLS support (gmail) fix
: franponce87 September 10, 2010, 01:34:19 PM
The following settings work fine for me:

Incoming settings:
Server address: imap.gmail.com
Connection method: IMAP. Using SSL
SSL port: 993

Smtp settings:
SMTP Server - smtp.gmail.com
SMTP Server Port - 465
SMTP Server Auth - Use incoming
Secure Connection - SSL

You may unlock your gmail captcha before setting your gmail account just in case. Click [ur=https://www.google.com/accounts/displayunlockcaptchal]here[/url] to do that

Regarding the default value being 10, you can change it at Administration>Configuration>Mailing - Email fetch limit

Greetings!

PS: What FO version are you using?
: Re: SSL/TLS support (gmail) fix
: chumby September 10, 2010, 07:13:35 PM
Hi am using 1.7

Have all those settings and unlocked the captcha.  Still the same error is appearing.

Could there be something wrong in my installation or a setting MY server?

Cheers
Martin
: Re: SSL/TLS support (gmail) fix
: franponce87 September 10, 2010, 07:45:45 PM
Are you sure you have written smtp.gmail.com? I have just noticed in your previous post you wrote stmp.gmail.com. Worths the shot checking right? :P

If that doesn't work.. I am not sure what could be wrong, specially because gmail is automatically recognized now and basically the only thing you must do is typing in your password

Greets!

PS: 1.7.1 version is out if you would like trying updating your files to see if it helps (plus it has new features and bug fixes)
: Re: SSL/TLS support (gmail) fix
: chumby September 10, 2010, 10:16:07 PM
Thanks for that... just checked.  No it is right... Google just put it in automatically.

Have just tried to update to 1.7.1 ... but doesn't work either.

I go to Administration --> Upgrade and the server sits there and thinks about doing something, but nothing is returned... no error messgae, prompt or anything?

Any thoughts here?

Cheers
Chumby
: Re: SSL/TLS support (gmail) fix
: chumby September 10, 2010, 10:20:44 PM
Turned off the firewall... had the message:

Success: failed to connect to server

and then the loading icon spins for a while and then nothing....

No upgrade made :(

Cheers
Chumby
: Re: SSL/TLS support (gmail) fix
: chumby September 10, 2010, 11:19:04 PM
Managed to upgrade manually... no worries there and things seem to be OK.

Still no change in being able to access GMAIL IMAP though....

ANything else I can check?

Cheers
Chumby
: Re: SSL/TLS support (gmail) fix
: franponce87 September 13, 2010, 01:30:38 PM
Ok so, if you are able to fetch the IMAP folder, that means the settings are all right, otherwise, there may be something missing..
If you can fetch the IMAP folders (for income settings) without problem AND the SMTP settings are the ones as above, but you cannot send emails, check if this email account is your default, if it is not, set it as default and try sending an email now. If you do not wish to set it as default, check how many emails accounts do you have and when you prepare a new email message ready to be sent, click on "From" and check where are you sending the email from...

If that doesn't help, check out at the Admin Panel, in your Cron Settings, if you have chosen to send the emails through Cron. If you have, you must set up your Cron correctly in order to send the emails, otherwise, they will never go out. Check this (http://forums.fengoffice.com/index.php?topic=4574.15) thread, last page, to see how to run the Cron.

Greetings!
: Re: SSL/TLS support (gmail) fix
: chumby September 13, 2010, 09:09:14 PM
Have tried the default mail settings... .doesnt make any difference.

Where do I specify to use Cron for mail?  Is that selected instead of SMTP or PHP in general settings somewhere?

Appreciate the help

Cheers
Chumby
: Re: SSL/TLS support (gmail) fix
: franponce87 September 17, 2010, 02:37:48 PM
You can find the Cron settings at Administration>Cron Events

Remember, you MUST RUN the cron in order to make it work, otherwise it will be useless. Read page 2 and 3 here (http://forums.fengoffice.com/index.php?topic=4574.0) for more info.

By the way, you ought to double check if the server you are running Feng Office at does not have those ports blocked!

Greetings!
: Re: SSL/TLS support (gmail) fix
: monmon1977 January 08, 2011, 01:12:09 AM
Thanks you
 :) :) :)
: Re: SSL/TLS support (gmail) fix
: keiex09 January 10, 2011, 12:50:14 AM
thanks. It's good. :D
: Re: SSL/TLS support (gmail) fix
: Fruity April 09, 2011, 12:22:22 AM
Thanks you. ;D
: Re: SSL/TLS support (gmail) fix
: puriku April 12, 2011, 01:55:14 AM
 :o :o
: Re: SSL/TLS support (gmail) fix
: front April 17, 2011, 11:51:37 PM
Wow!!
: Re: SSL/TLS support (gmail) fix
: swrrty April 18, 2011, 04:20:50 AM
 :P :P
: Re: SSL/TLS support (gmail) fix
: super09813 April 18, 2011, 06:18:48 AM
 ;D ;D
: Re: SSL/TLS support (gmail) fix
: montor159 April 26, 2011, 11:14:04 PM
Thank you.
: Re: SSL/TLS support (gmail) fix
: bombam May 04, 2011, 04:40:20 AM
Thank you for the info.
: Re: SSL/TLS support (gmail) fix
: daltontom7782 April 12, 2012, 06:05:26 PM
Thank you!
Will surely look over at this. :)