Feng Forum

Support => Older versions => Feng Office 1 => : laurg February 05, 2009, 02:05:51 PM

: Uploading files error
: laurg February 05, 2009, 02:05:51 PM
Hello. First of all I would like to say thank you for sharing this great software with everyone.
I've just installed the latest version and everything seems to be working fine besides the file upload.
Every time I try to upload a file, any kind of file I get the general error "Failed to upload file"
I never go over the max upload size of 2MB.
My system is a Freebsd webserver with Apache and MySQL and all the settings are in place. I have a multitude of other LAMP apps installed that worked just fine.
I really need some help with this. Thanks.
: Re: Uploading files error
: ignacio February 06, 2009, 09:41:12 AM
Some suggestions:

Verify if the upload folder is writable.

If you're using database storage (by default you'd be using file system storage), you need to make sure you are not uploading files too large for your database setting (if uploading a really small file doesn't work either this is not the problem).

Set DEBUG to true in 'config/config.php' and check if you get any error messages in 'cache/log.php'.
: Re: Uploading files error
: laurg February 08, 2009, 07:56:09 PM
Thanks for the suggestions Ignacio.
I looked at the error log and I found out that the error was Open_Base_Dir restriction in the config file.
So I went ahead and set it to None and now it works. Thanks again.
: Re: Uploading files error
: janvanhapert February 13, 2009, 09:18:54 AM
I'm having the same trouble.
I've tried these steps, but don't seem to get trough.
In the log.php:
Session "default" started at 2009-02-13T11:47:27+0000
#1 ERROR: Error: copy() [<a href='function.copy'>function.copy</a>]: SAFE MODE Restriction in effect.  The script whose uid is 10173 is not allowed to access /var/www/vhosts/xxx/httpdocs/opengoo/upload/d1ede/e8681/2208b owned by uid 48 in '/var/www/vhosts/xxx/httpdocs/opengoo/library/filerepository/backend/FileRepository_Backend_FileSystem.class.php' on line 171 (error code: 2)
#2 ERROR: Error: copy(/var/www/vhosts/xxx/httpdocs/opengoo/upload/d1ede/e8681/2208b/d4309a4c90b8c8a5c85de2969) [<a href='function.copy'>function.copy</a>]: failed to open stream: No such file or directory in '/var/www/vhosts/xxx/httpdocs/opengoo/library/filerepository/backend/FileRepository_Backend_FileSystem.class.php' on line 171 (error code: 2)
Time since start: 0.10792899131775 seconds

I've tried to upload a file (76kb) and  upload an .ics to the calendar. No luck yet, and opengoo looks so nice!...