Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - carcam

Pages: [1] 2
1
Getting Started / Reorder Workspaces
« on: August 11, 2010, 11:32:32 AM »
Hi there, after a while using Fengoffice I wonder if there is a way of reordering the workspaces  ??? Is this possible?

2
I had a 1.6.2 Feng and I have tried the update to 1.7.

I unzipped the files into the directory and I accessed the public/upgrade address and everything was ok.

Nevertheless when I access to the site I can see none of my content. The only thing that are shown are the header with the Feng Logo and the little menu in the upper right corner with the items: "logout", "administration", "account" and "help". When I try one of these links they open a new window with the same content as before.

Right below these I can see the footer of the application with FengOffice site link

After activating the debug mode, I get the following errors:

Trying to logout:

Code: [Select]
Fatal error: Undefined class constant 'ACTION_LOGOUT' in [SITEFOLDER]/application/controllers/AccessController.class.php on line 412
Trying to access into "account":
Code: [Select]
Fatal error: Call to undefined method User::isGuest() in /[SITEFOLDER]/application/helpers/permissions.php on line 40
I have tryed with two different browsers (Midori and Iceweasel) with the whole cache cleaned and even with the private mode of Iceweasel.

Any ideas?

3
Feature requests / [1.7 Beta 1] Extend pdf export
« on: March 21, 2010, 10:32:41 AM »
First of all I want to congratulate the developers for this new version. From all the updates I have made, it seems the most stable one and the latest activity module is very impressive.

I have also noticed that you have included the pdf export functionality for the reports, so I just wondered if it would be very hard to extend the functionality to the html documents so that we don't have to deal with external programs like with the current plugin.

I want to thanks again your great work and efforts and for sure I'll report every bug I find ;)

4
Older versions / [1.6.2] Accessing the trashcan gives me a 500 error
« on: February 19, 2010, 10:26:52 PM »
When I try to access to the trashcan I get a 500 error and it shows nothing. Is this action linked to the php.ini variables or so?

5
Older versions / [1.6.2] log.DateField is not a constructor
« on: February 19, 2010, 10:08:14 PM »
Hi there, I am getting this error from my openoffice when I try to access to a task. Any idea what is it for?

6
General Discussion / Not very comfortable with the new site organization
« on: December 29, 2009, 08:28:02 PM »
Hi guys, since you have integrated the opengoo site into the feng office one I don't feel very comfortable with the access to the forum.

I know it's only 2 clicks far, but it really makes a difference for me. Besides the wrapping (sorry, Joomla speaking) into the iframe seems to be slower.

Would it be possible to have a more direct link or at least a forum without frames?

PS: You are also killing the SMF mobile facilities with the iframe!!!

7
Feature requests / Contacts assigned to users
« on: November 28, 2009, 10:08:30 AM »
I think it could be great if you can specify which user (employee) is related with a specific contact (client).  ;)

8
Feature requests / Backup Security Improvements
« on: September 20, 2009, 11:16:45 AM »
Although you highly recommend to delete the backups after downloading them, I think you could add some simple features to enhance the security of the system:

1) Add a password to the zip file.
2) Storing the configuration parameters on the Database

Hope this could be useful.  ;)

9
Older versions / [1.5.3] Error 500 when trying to backup
« on: September 20, 2009, 11:12:17 AM »
I am trying to create an Opengoo Backup (plugin installed), but the system continuosly gives me an Error 500. Which could this mean?

10
How To's / Security Concerns
« on: September 17, 2009, 03:32:18 AM »
Hi to all, I am not a web security expert, but I am really concerned about this issue and I have some questions and ideas about it.

Recently I have performed an Opengoo hosting migration, and I could download the backup package directly from my server using wget. The point is that the backup package name is generic, so If i don't remove the backup files after their creation, everyone with a minimum knowledge about Opengoo could get my backups. This is a real problem when the backup file contains the DB, and the files on the server. I think that this issue could be solved with one of these (or both) simple actions:

1) Adding a password to the files (This would really make the point)
2) Asking the opengoo Administrator for a different backup filename.

What do you think?

11
Older versions / [1.5.3] Can't link objects
« on: September 03, 2009, 04:44:45 AM »
I have just installed 1.5.3 and I can't link objects. When I click the link object link, the window to select the object, does not pop up.

12
Older versions / [1.5.2] Mindmap visor, overlap popups
« on: September 02, 2009, 08:27:37 AM »
When I try to link an object to an existent mindmap, the pop up is overlapped by the midnmap visor.

13
I have checked the option to make mandatory the comments on every document revision, and when I want to update a file with comments not allowed, I have to make a revision comment to save the file.

The only way to save the new version is checking the save old version option, typing something in the revision comment, and unchecking the old version box again.

14
Feature requests / Mobile version
« on: August 20, 2009, 12:04:54 PM »
As I am right now on a bus, I am thinking about a mobile version for Opengoo. What do you think?

15
Older versions / Funny problem with imap email account
« on: August 15, 2009, 07:59:11 AM »
I am trying to configure an imap account from one hosting company at my opengoo. When I try to get the impa folders, I get nothing and this is the error log for these attemps:

Code: [Select]
-------------------------------------------------------------------------------

Session "default" started at 2009-08-15T10:50:05+0000
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to tcp://mail.1stdomain.com:143 (Connection timed out) in '/home/xxxxx/public_html/opengoo/library/PEAR/Net/Socket.php' on line 138 (error code: 2)
#2 DEBUG: Connection timed out
#3 DEBUG: #0 /home/xxxxx/public_html/opengoo/application/controllers/MailController.class.php(1574): MailUtilities->getImapFolders(Object(MailAccount))
    #1 /home/xxxxx/public_html/opengoo/environment/classes/controller/Controller.class.php(76): MailController->fetch_imap_folders()
    #2 /home/xxxxx/public_html/opengoo/environment/classes/controller/PageController.class.php(62): Controller->execute('fetch_imap_fold...')
    #3 /home/xxxxx/public_html/opengoo/environment/classes/Env.class.php(133): PageController->execute('fetch_imap_fold...')
    #4 /home/xxxxx/public_html/opengoo/init.php(149): Env::executeAction('mail', 'fetch_imap_fold...')
    #5 /home/xxxxx/public_html/opengoo/index.php(9): require('/home/xxxxx/...')
    #6 {main}
#4 ERROR: Error: Undefined variable: imap_folders in '/home/xxxxx/public_html/opengoo/application/views/mail/fetch_imap_folders.php' on line 1 (error code: 8)
#5 ERROR: Error: Undefined variable: genid in '/home/xxxxx/public_html/opengoo/application/views/mail/fetch_imap_folders.php' on line 28 (error code: 8)
#6 FATAL: exception 'DBQueryError' with message 'Query failed with message 'MySQL server has gone away'' in /home/xxxxx/public_html/opengoo/environment/library/database/adapters/AbstractDBAdapter.class.php:386
    Stack trace:
    #0 /home/xxxxx/public_html/opengoo/environment/library/database/adapters/AbstractDBAdapter.class.php(272): AbstractDBAdapter->prepareAndExecute('ROLLBACK', NULL)
    #1 /home/xxxxx/public_html/opengoo/environment/library/database/adapters/AbstractDBAdapter.class.php(346): AbstractDBAdapter->execute('ROLLBACK')
    #2 /home/xxxxx/public_html/opengoo/environment/library/database/DB.class.php(259): AbstractDBAdapter->rollback()
    #3 /home/xxxxx/public_html/opengoo/init.php(150): DB::rollback()
    #4 /home/xxxxx/public_html/opengoo/index.php(9): require('/home/xxxxx/...')
    #5 {main}
#7 ERROR: Error: Cannot modify header information - headers already sent by (output started at /home/xxxxx/public_html/opengoo/application/layouts/json.php:2) in '/home/xxxxx/public_html/opengoo/environment/functions/general.php' on line 378 (error code: 2)
Time since start: 45.1256539822 seconds
-------------------------------------------------------------------------------

The odd thing is that when I try to configure another imap account from the same hosting company with another domain name, everything goes fine. The latest mail account is in the same server of Opengoo.

Any ideas? Is it an Opengoo problem or a Hosting problem?

Pages: [1] 2