Author Topic: help! missing lang.js  (Read 4198 times)

villcom

  • Newbie
  • *
  • Posts: 2
    • View Profile
help! missing lang.js
« on: October 23, 2012, 08:19:23 AM »
Hi to everyone,

I've just installed the latest version 2.2 and I have several "Missing lang.js: information:
Errore 500: Internal Server Error" on my home (I'm using ITALIAN language). How can I fix it? I searched everywhere in web but all the solutions I found didn't work for me.

Can you help me please?
Thank you!

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: help! missing lang.js
« Reply #1 on: October 23, 2012, 09:12:30 AM »
Hello there! Welcome to Feng Office Forums!
Missing lang means there is no translation for that text in that language. We officially support English and Spanish as we speak both languages, but not the rest.. which are translations done by our clients or by Community users that would like to help out other people as well.
Should you consider translating the Italian files, please drop me a PM or an email and I will guide you through our translation tool.

Thanks for your interest!

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

villcom

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: help! missing lang.js
« Reply #2 on: October 23, 2012, 10:12:46 AM »
Thank you Francisco!
I have only one doubt... if the italian translation doesn't exist, why is my fengoffice in italian? Maybe the translation isn't complete...

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: help! missing lang.js
« Reply #3 on: October 29, 2012, 08:59:16 AM »
Hello there! What I meant by that text, I meant that sentence, not the whole language. As you correctly mention, it is not complete. Please let me know if you would like to help out with it. Your help would be much appreciated.

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

apmuthu

  • Freshman
  • *
  • Posts: 28
    • View Profile
Re: help! missing lang.js
« Reply #4 on: December 26, 2012, 11:23:26 PM »
In the latest v2.2.1, all installs well and all the language strings show up too. After we upload the company logo, the "Missing lang" comes up only on the tab names. and permission listing page for the tab names.

en_us is used.

Tried to use the undocumented feature of DEBUG_DB = true and DEBUG_TIME = true in config/config.php to no avail.

lang.js is now loaded thru' app.js

even after making line 18 in public/assets/javascript/og/app.js as:
value=name;
the error still occurs.


franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: help! missing lang.js
« Reply #5 on: December 27, 2012, 08:10:48 AM »
The 2.2.2 Final version has some improvements and fixes here.
Please try it out with that one.

Best regards,
Francisco
« Last Edit: December 27, 2012, 02:04:36 PM by franponce87 »
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!