Author Topic: Solving Missing lang issue  (Read 2048 times)

apmuthu

  • Freshman
  • *
  • Posts: 28
    • View Profile
Solving Missing lang issue
« on: December 27, 2012, 06:45:37 AM »
FengOffice v2.2.1 and v2.2.2:

If we try to go to Administrator -> Tabs and save any changes, the tab names become "Missing lang".

Solution:

First make the corrections in the two posts:
hxxp://forums.fengoffice.com/index.php?topic=15792.0
and
hxxp://forums.fengoffice.com/index.php?topic=15791.0

Then make the following correction - spelling mistake in the conditions field:
Line 11 of application/models/tab_panels/TabPanels.class.php
       return self::findAll(array("condtitions" => "`enabled` = 1"));
should be
       return self::findAll(array("conditions" => "`enabled` = 1"));

Viola! The error goes away! That was 18 hours of searching for a bug successfully....
« Last Edit: December 30, 2012, 07:27:28 AM by apmuthu »

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: Solving Missing lang issue
« Reply #1 on: December 27, 2012, 08:15:02 AM »
This should have been solved for the 2.2.2 RC as far as I am aware.
Nonetheless, thank you very much for this report, and all the other ones.
It would be best if you could report them here though:
http://www.fengoffice.com/web/bugs/login_page.php

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

apmuthu

  • Freshman
  • *
  • Posts: 28
    • View Profile
Re: Solving Missing lang issue
« Reply #2 on: December 27, 2012, 01:19:22 PM »
Actually it would be nice to have the bug tracker in read only mode atleast, without having to login, just like how the forum is. Since the developer repo is not open to the public, there is no way to contribute in synch without having to fork it and that is too much a hassle.

Both the code and the db schema need a whole overhaul - 98 tables in v2.2.1 is way too much.

The forum seems to have all posts in centered format mode and we have to manually left align each post!

It would also be nice to allow the posting of URLs atleast for certain categories of members (include me there :) ).

Have provided a link to your hosted offering at the ProxmoxVE Project page along with a full disclosure so that there would be no appropriateness / legal issues.

pve.proxmox.com/wiki/FengOffice

This issue is not fixed even in v2.2.2 and this post is still valid.
« Last Edit: December 30, 2012, 07:28:32 AM by apmuthu »