Author Topic: SSL/TLS support (gmail) fix  (Read 36213 times)

gylf

  • Newbie
  • *
  • Posts: 28
    • View Profile
SSL/TLS support (gmail) fix
« on: October 06, 2008, 05:30:19 PM »
Gmail requires SSL/TLS support to work properly and I am a faithful Gmail user.  I noticed a few other on here are as well.  So here is a fix to get Gmail (or another encrypted mail server) working with OpenGoo:

Download and install Stunnel (http://www.stunnel.org/)
It is a free program which will sit on your computer and download your email on command.  It supports SSL/TLS. 
Now edit your configuration file to look something like:

; Use it for client mode
client = yes

; Service-level configuration

[pop3s]
accept  = 110   
connect = pop.gmail.com:995

[ssmtp]
accept  = 25
connect = smtp.gmail.com:465

Now in OpenGoo put in your full email address for username and your password.  Set your Pop3 server to 127.0.0.1 and your smtp server to 127.0.0.1 with port 25.

It should now work!

conrado

  • Administrator
  • Hero Member
  • *****
  • Posts: 943
  • Conrado
    • View Profile
    • Feng Office
    • Email
Re: SSL/TLS support (gmail) fix
« Reply #1 on: October 06, 2008, 05:46:05 PM »
Thank you!

Will definitely take a look at this.
Get Official Support for your Feng Office. Support the development team. Sign up for a Free Trial here.

cabeza

  • Administrator
  • Hero Member
  • *****
  • Posts: 1004
    • View Profile
    • Feng Office
Re: SSL/TLS support (gmail) fix
« Reply #2 on: October 07, 2008, 09:33:14 AM »
Thank you gylf

lega

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: SSL/TLS support (gmail) fix
« Reply #3 on: November 11, 2008, 11:11:32 AM »
Gmail requires SSL/TLS support to work properly and I am a faithful Gmail user.  I noticed a few other on here are as well.  So here is a fix to get Gmail (or another encrypted mail server) working with OpenGoo:

Download and install Stunnel (http://www.stunnel.org/)
It is a free program which will sit on your computer and download your email on command.  It supports SSL/TLS. 
Now edit your configuration file to look something like:

; Use it for client mode
client = yes

; Service-level configuration

[pop3s]
accept  = 110   
connect = pop.gmail.com:995

[ssmtp]
accept  = 25
connect = smtp.gmail.com:465

Now in OpenGoo put in your full email address for username and your password.  Set your Pop3 server to 127.0.0.1 and your smtp server to 127.0.0.1 with port 25.

It should now work!

Hi! I just discovered OpenGoo and it feels write :)
However I have problems with setting up my Gmail
I folowed your Instructions but nada :(

I have to say that I use bluehost, and I uploaded the file on the ~/public_html directory and opengoo is at ~/public_html/opengoo

In the same time i cant folow the 4th step of the instructions
Quote
4. Add stunnel invocation to your system's startup files.
   For SysV-compatible init you can use stunnel.init script.

     or

   Modify /etc/services and /etc/inetd.conf, restart inetd (inetd mode).

   See the manual for details.


Since I dont have access on this directories!
any suggestions?

Thanks in advance :)

ignacio

  • Administrator
  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: SSL/TLS support (gmail) fix
« Reply #4 on: November 11, 2008, 12:57:30 PM »
Another workaround until we support SSL/TLS is to setup Gmail to forward all your email to another email account that supports POP3 without SSL (in your case, a bluehost email account).

It's far from ideal and you won't be able to retrieve your previous email, but it is better than nothing I guess...

lega

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: SSL/TLS support (gmail) fix
« Reply #5 on: November 12, 2008, 04:14:58 AM »
Well thanks on this! thats what I'll do!

jgramosli

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Re: SSL/TLS support (gmail) fix
« Reply #6 on: February 04, 2009, 11:23:10 AM »
Has anyone managed top get this working with the 1.2 rc1?

I've got my other email accounts working, but not with Gmail yet.  Just seems to do nothing, how the hell do you debug this system? Where are the logs kept?

ignacio

  • Administrator
  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: SSL/TLS support (gmail) fix
« Reply #7 on: February 05, 2009, 09:25:17 AM »
You have to set DEBUG to true in 'config/config.php'. There's a log in 'cache/log.php'.

garoo

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: SSL/TLS support (gmail) fix
« Reply #8 on: March 08, 2010, 06:46:34 PM »
Hi fellas!
Using mandriva and have same problem with the gmail ssl.
Is anybody solve this problem with linux?

Boxerworks

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: SSL/TLS support (gmail) fix
« Reply #9 on: August 20, 2010, 12:19:33 PM »
Cannot connect to my imap account on Google Apps.  So, I turned on debug as suggested above and here is the list of log messages from just now:
-------------------------------------------------------------------------------

Session "default" started at 2010-08-20T13:34:08+0000
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://smtp.gmail.com:587 (Connection refused) in '/home/motorrad/public_html/office/library/swift/lib/Swift/Connection/SMTP.php' on line 149 (error code: 2)
Time since start: 0.65101003646851 seconds
-------------------------------------------------------------------------------

Session "default" started at 2010-08-20T15:00:16+0000
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://imap.googlemail.com:993 (Connection refused) in '/home/motorrad/public_html/office/library/PEAR/Net/Socket.php' on line 138 (error code: 2)
Time since start: 0.39326596260071 seconds
-------------------------------------------------------------------------------

Session "default" started at 2010-08-20T15:16:28+0000
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://imap.googlemail.com:993 (Connection refused) in '/home/motorrad/public_html/office/library/PEAR/Net/Socket.php' on line 138 (error code: 2)
Time since start: 0.16923689842224 seconds


Can someone please point me in the right direction as to how to fix this?

chumby

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Re: SSL/TLS support (gmail) fix
« Reply #10 on: September 08, 2010, 03:48:53 AM »
Hi,

Has anyone found a definate fix to this.  I just cant get GMail working - can not send mail.

The message comes up when I try to send an email:

ERROR: The server does not support SSL.

I have IMAP enabled in gmail and the right settings appear to be self populating.  I am using the current version of feng 1.7

Please help,

Thanks
Chumby

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1660
    • View Profile
    • Email
Re: SSL/TLS support (gmail) fix
« Reply #11 on: September 08, 2010, 12:54:46 PM »
Boxerworks, which FO version are you using?

Chumby, what settings are you using? For gmail accounts, the IMAP port is 993 and the SMTP is 465, and it uses SSL authentication.
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

chumby

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Re: SSL/TLS support (gmail) fix
« Reply #12 on: September 08, 2010, 06:13:58 PM »
Thanks Fran...

Yes I am using those settings.  Gmail fills them in automatically when I start to set up the account.

When I check ail, like 10 emails come in and thats it.  When I go to send email it comes up with the server SSL error.

Haven't been able to find anything at all to help...

Apprecite the help.

Cheers
Martin

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1660
    • View Profile
    • Email
Re: SSL/TLS support (gmail) fix
« Reply #13 on: September 09, 2010, 12:10:45 AM »
No problem at all. By the way, you download only 10 emails every time you check your email, because you haven't changed that default value at the administration panel, which happens to be 10. If you want to download EVERY single email you have in that account, you should download your emails through the Cron (read page 2 and 3 here for more info).

About the SSL server error when sending the emails, check your email account configuration, at the outgoing part, if it is marked as SSL too, and the authentication being the same as incoming emails.

Greetings!
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

chumby

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Re: SSL/TLS support (gmail) fix
« Reply #14 on: September 09, 2010, 12:23:22 AM »
Yes SMTP is set to SSL as well... my settings in SMTP are:

SMTP Server - stmp.gmail.com
SMTP Server Port - 465
SMTP Server Auth - Use incoming
Secure Connection - SSL

Does that help?

Also where is the defalt set to 10 for emails?  I cannot see that in my admin panel.

Thanks
Martin

 

anything