Author Topic: Error after upgrade from 2.5.1-beta to 2.5.1  (Read 2209 times)

lpriem

  • Newbie
  • *
  • Posts: 5
    • View Profile
Error after upgrade from 2.5.1-beta to 2.5.1
« on: February 27, 2014, 01:24:34 PM »
Hello,

After upgrading from 2.5.1-beta to 2.5.1 by following the update-instructions, there is an error occuring while retrieving e-mail (IMAP, from imap.gmail.com).

In the logging the error is logged as mentioned at the end of this post.

Before upgrading, so while using 2.5.1-beta, the e-mail retrieving didn't work at all (no errors logged), although the settings (like the fetch-limit) were set OK (unlimited). It's a clean install of 2.5.1-beta.

Is anyone experiencing the same problems? Anyone a suggestion for solving this problem?

Thanks for your replies!

-----------LOG------------

Session "default" started at 2014-02-27T16:11:14+0000
#1 DEBUG: SQL ERROR: Query failed with message 'Unknown column 'e.conversation_last' in 'where clause'' -
                 SELECT SQL_CALC_FOUND_ROWS * FROM fo_objects o
                 INNER JOIN  fo_mail_contents e ON e.object_id = o.id
                 
                 
                 WHERE
                    EXISTS (
                                     SELECT object_id FROM fo_sharing_table sh
                                     WHERE o.id = sh.object_id
                                     AND sh.group_id  IN (
                                                    SELECT permission_group_id FROM fo_contact_permission_groups WHERE contact_id = 2
                                                    )
                               )
                   AND    true
                   AND o.object_type_id = 22
                   AND `o`.`trashed_on` = '0000-00-00 00:00:00' AND `o`.`archived_on` = '0000-00-00 00:00:00'  AND e.account_id = '3'   AND e.conversation_last = 1 AND  e.state IN ('0','5')
                ORDER BY `received_date` DESC
                 LIMIT 0 , 50
#2 FATAL: exception 'DBQueryError' with message 'Query failed with message 'Unknown column 'e.conversation_last' in 'where clause''' in D:\inetpub\vhosts\XXXX\environment\library\database\adapters\AbstractDBAdapter.class.php:392
    Stack trace:
    #0 D:\inetpub\vhosts\XXXX\environment\library\database\adapters\AbstractDBAdapter.class.php(310): AbstractDBAdapter->prepareAndExecute('????    ?SELECT...', NULL)
    #1 D:\inetpub\vhosts\XXXX\environment\library\database\DB.class.php(213): AbstractDBAdapter->executeAll('????    ?SELECT...', NULL)
    #2 D:\inetpub\vhosts\XXXX\application\models\ContentDataObjects.class.php(484): DB::executeAll('????    ?SELECT...')
    #3 D:\inetpub\vhosts\XXXX\plugins\mail\application\models\mail_contents\MailContents.class.php(290): ContentDataObjects->listing(Array)
    #4 D:\inetpub\vhosts\XXXX\plugins\mail\application\controllers\MailController.class.php(2598): MailContents->getEmails('3', 'received', 'all', 'all', Array, '0', '50', '`received_date`', 'DESC', Array, NULL, 1)
    #5 D:\inetpub\vhosts\XXXX\plugins\mail\application\controllers\MailController.class.php(2563): MailController->getEmails(Array, Array, '0', '50', '`received_date`', 'DESC', Array, 1)
    #6 D:\inetpub\vhosts\XXXX\environment\classes\controller\Controller.class.php(76): MailController->list_all()
    #7 D:\inetpub\vhosts\XXXX\environment\classes\controller\PageController.class.php(62): Controller->execute('list_all')
    #8 D:\inetpub\vhosts\XXXX\environment\classes\Env.class.php(129): PageController->execute('list_all')
    #9 D:\inetpub\vhosts\XXXX\init.php(173): Env::executeAction('mail', 'list_all')
    #10 D:\inetpub\vhosts\XXXX\index.php(9): require('D:\inetpub\vhos...')
    #11 {main}

lpriem

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Error after upgrade from 2.5.1-beta to 2.5.1
« Reply #1 on: February 27, 2014, 03:33:53 PM »
'Solved' it by adding a column.

ALTER TABLE  `fo_mail_contents` ADD  `conversation_last` INT NOT NULL AFTER  `sync`

Anyone an idea what caused this problem? And, did I add the column with the right parameters?

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: Error after upgrade from 2.5.1-beta to 2.5.1
« Reply #2 on: February 28, 2014, 09:52:53 AM »
Seems like you were missing SQL structures as the Email plugin did not get upgraded.

Please have a look at this thread:
http://forum.fengoffice.com/index.php?topic=19137.0

Hope it helps.

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

lpriem

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Error after upgrade from 2.5.1-beta to 2.5.1
« Reply #3 on: February 28, 2014, 12:43:07 PM »
Thanks! That solved the problem.

siagris

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Re: Error after upgrade from 2.5.1- to 2.7.1
« Reply #4 on: November 10, 2014, 04:36:41 PM »
hello
i upgrade from 2.5.1 to 2.7.1.6 and the mail plugin can not be updated
There is a new version of mail. Update now from Version 7 to Version 9
but when you press it nothing happens
i have the conversation_last coclum correct as i saw it from another test db
thanks

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: Error after upgrade from 2.5.1-beta to 2.5.1
« Reply #5 on: March 19, 2015, 11:53:21 AM »
Hi there!

If you are still experiencing issues with the upgrade of the email module, have you tried with the latest version available of FO?
Do note that the upgrade may take a while (many hours) depending on the amount of emails you have.

Best,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

 

anything