Author Topic: Soporte PHP 7 - PHP Deprecated: mysql_connect():  (Read 1793 times)

erama

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • erama
Soporte PHP 7 - PHP Deprecated: mysql_connect():
« on: July 06, 2016, 05:51:19 PM »
Hola soy un fiel usuario de FengOffice, pero últimamente me encuentro algunos errores y problemas con las actualizaciones. Hace unos días actualice mi servidor ,ahora esoty corriendo PHP 7 , y al intentar actualizar a la última versión de FengOffice me encuentro con estos errores en el log:
 PHP Deprecated:  mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /var/www/clients/client1/web6/web/public/upgrade/library/classes/ScriptUpgrader.class.php on line 147, referer: ......../public/upgrade/

y cuando trato de crear un nuevo usuario el Debug muestra este error:
-------------------------------------
Query failed with message 'Unknown column 'can_instantiate_templates' in 'field list''
Error params:
File:   /var/www/clients/client1/web6/web/environment/library/database/adapters/AbstractDBAdapter.class.php
Line:   395
Sql:   SELECT `permission_group_id`, `can_manage_security`, `can_manage_configuration`, `can_manage_templates`, `can_instantiate_templates`, `can_manage_time`, `can_add_mail_accounts`, `can_manage_dimensions`, `can_manage_dimension_members`, `can_manage_tasks`, `can_task_assignee`, `can_manage_billing`, `can_view_billing`, `can_see_assigned_to_other_tasks`, `can_update_other_users_invitations`, `can_link_objects` FROM `fo_system_permissions` WHERE `permission_group_id` = '4'
Error number:   1054
Error message:   Unknown column 'can_instantiate_templates' in 'field list'
----------------------------------------------------------------------------------------

Tal como dice, esa columna no existe en mi DB, cómo podría hacer para actualizar mi DB, sin borrar todo?

Muchas gracias



steveg

  • Full Member
  • ***
  • Posts: 175
    • View Profile
Re: Soporte PHP 7 - PHP Deprecated: mysql_connect():
« Reply #1 on: July 09, 2016, 02:43:38 PM »
I'm pretty sure php7 is not supported.  Use php 5.4+.

 

anything