Author Topic: [3.4.3] Field `description` does not have a default value  (Read 854 times)

Martin Lancaster

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
[3.4.3] Field `description` does not have a default value
« on: August 05, 2016, 11:02:39 AM »
Hi all,
Trying to install Feng Community onto Windows 2008 Server R2, Sp1 using version FengOffice 3.4.3.
Running Apache 2.4.23 (Win 64), PHP 5.6.24 and MySQL 5.6.25

After the installer has finished, the Step 4 screen reports that
(1) database connection has been established successfully
(2) InnoDB storage engine is supported
(3) Tables created in `testfengoffice' (Executed queries: 107)
(4) Failed to import initial data. MySQL said: Field `description` doesn't have a default value.

Searched this community support site and found Topic: 3.4.1 failed in import initial data
Removed the string `STRICT_TRANS_TABLES` from SQL-Mode in my.ini, bounced the MySQL service, dropped the created database, and rerun. Same error.

Can anyone suggest a workaround or fix for this problem please?

Thanks in advance

natalia.martinez

  • Administrator
  • Jr. Member
  • *****
  • Posts: 69
    • View Profile
Re: [3.4.3] Field `description` does not have a default value
« Reply #1 on: September 13, 2016, 11:19:27 AM »
Hello Martin,

Thanks for reaching us!

Based on the information provided, there seems to be a Mysql configuration issue.

Many thanks for reporting this.
And sorry for my delayed answer. For bug reports and faster troubleshooting, we always suggest using our bug tracking system for bugs reported by the (unsupported) Community Edition users:
http://www.fengoffice.com/web/bugs/

It is a much better system than the forum. We recommend using the forum only for how-to's and issues which you don't know whether are bugs or not.

PS: If you have a support plan contracted with us, you are welcome to contact us directly for personalized support.

Natalia


BB

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [3.4.3] Field `description` does not have a default value
« Reply #2 on: October 02, 2017, 07:03:24 AM »
FengOffice is not working with MariaDB 10.2.4 or newer (and probably MySQL 5.7.7+).

It is not good for changing server default settings mariadb.com/kb/en/library/sql-mode/

I think, for workaround, it should be enough that you put SQL_MODE after every connect.
SQL_MODE can be changed per session.

Of course it would be a lot nicer if you add default values to columns.

(xxx:xxx.mysql.zonevs.eu) [(none)]> select @@sql_mode;
+-------------------------------------------------------------------------------------------+
| @@sql_mode |
+-------------------------------------------------------------------------------------------+
| STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
+-------------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

(xxx:xxx.mysql.zonevs.eu) [(none)]> set session sql_mode='';
Query OK, 0 rows affected (0.00 sec)

(xxx:xxx.mysql.zonevs.eu) [(none)]> select @@sql_mode;
+------------+
| @@sql_mode |
+------------+
| |
+------------+
1 row in set (0.00 sec)

Best regards,
Silver Asu
Zone.ee

 

anything
anything