Author Topic: compatibility with PHP 7.2?  (Read 21 times)

simonwenger

  • Freshman
  • *
  • Posts: 31
    • View Profile
compatibility with PHP 7.2?
« on: September 12, 2018, 04:36:56 AM »
Hello

I am using Community Edition version 3.4.0.17 and have not been able to update ever since. When I install a new version (which I have done before plenty of times) I get a DB error.
But that's not why I am asking for your help :-)

My provider has announced that support for PHP 5.6. will be stopped by dec 2018. Yesterday they have switched and my installation was no longer accessible. I was able to switch back to 5.6. for the moment, but support will definately terminate by the end of the year.

My questions:
- is a newer version of FengOffice compatible with the new standard? -> then I will try to get around the update error
- is there a workaround for the outdated version? -> in case I cannot update my installation

Thanks so much for your help!
Simon

biblefusion

  • Freshman
  • *
  • Posts: 15
    • View Profile
Re: compatibility with PHP 7.2?
« Reply #1 on: September 13, 2018, 05:07:17 AM »
Hi Simon

I have struggled with this issue for some time. I stand corrected, but the latest community edition of Feng Office, 3.5.1.5 is NOT compatible with PHP 7 and above.

Thanks
Peter

steveg

  • Full Member
  • ***
  • Posts: 176
    • View Profile
Re: compatibility with PHP 7.2?
« Reply #2 on: September 15, 2018, 03:46:08 PM »
No php7 compatibility.  It feels like this project is dead, or moved to private pay.

We use the community version 3.5.1.5 in production, but it's in need of updating.  I have found a 3.6.0RC on github, but not sure if it's official, or not.  I haven't yet had a chance to trial it, but I see nothing significant that would make it play nice with php7.

Is there a desire to fork this project, and rebuild it for the future? (ie, php7)

 

anything