Author Topic: Index.php doesn't start :-(  (Read 122 times)

isukug

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Index.php doesn't start :-(
« on: March 15, 2019, 07:58:23 AM »
Hello Feng Community,

i can't start the Index.php on my Debian. I get the following message when starting the index. php :
<?php

  if(!version_compare(phpversion(), '5.0', '>=')) {
    die('<strong>Installation error:</strong> in order to run Feng Office you need PHP5. Your current PHP version is: ' . phpversion());
  } // if
 
  require 'init.php';
 
?>

Installed is php7.0 and Feng3.7.0.5

Has any one idea what I can do?
Thx

Ronbigly

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Index.php doesn't start :-(
« Reply #1 on: March 19, 2019, 08:44:51 PM »
Same problem here... Index.php error

JasonLABS

  • Newbie
  • *
  • Posts: 7
    • View Profile
    • JasonLABS
Re: Index.php doesn't start :-(
« Reply #2 on: April 10, 2019, 06:23:23 PM »
It looks like FengOffice 3.7.0 and newer require at least PHP 7.1
http://www.fengoffice.com/web/wiki/doku.php/installation:server_reqs

Also make sure you have all php modules and other software listed installed on your server.

As a side note, as of Feb 3, 2019 according to the following GitHub issue, it looks like there are problems with php 7.0 and 7.2. However, 7.1 seems to work:
https://github.com/fengoffice/fengoffice/issues/13

 

anything