Author Topic: v.15.3 to v. 1.6 Failed to execute DB schema transformations  (Read 7609 times)

icfw

  • Full Member
  • ***
  • Posts: 122
    • View Profile
v.15.3 to v. 1.6 Failed to execute DB schema transformations
« on: December 12, 2009, 09:18:58 PM »
attempted upgrade but failed. The following error message occurs:

■Failed to execute DB schema transformations. MySQL said: Duplicate column name 'archived_on'
■Error upgrading to version 1.6

When attempting to login, v. 1.6 is being displayed at the bottome of the screen, new features appear to be there, but all email accounts were gone. I would have to setup email accounts for all users within the OpenGoo.

Is there a fix to this problem? Can the upgrade issue be fixed? I had to restore my backup to v. 1.5.3

Thanks.
.Mirsad
« Last Edit: December 13, 2009, 02:21:41 AM by icfw »

rportinga

  • Full Member
  • ***
  • Posts: 117
    • View Profile
    • Bauer Bros. Construction, Inc.
    • Email
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #1 on: January 06, 2010, 08:05:14 PM »
I'm getting the same error...

Anyone?
Rob Portinga
Bauer Bros. Construction, Inc.

rportinga

  • Full Member
  • ***
  • Posts: 117
    • View Profile
    • Bauer Bros. Construction, Inc.
    • Email
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #2 on: January 08, 2010, 01:21:27 PM »
ok, nearly a month this question has been up here with no responses... kinda frustrating.

Second time I've had issues where upgrading has rendered my install unusable.
Rob Portinga
Bauer Bros. Construction, Inc.

matsonda

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #3 on: January 17, 2010, 09:18:51 PM »
I set up my v1.5.3 exactly as specified for the automatic upgrade with folder permissions and got an error message saying: "You already have upgraded to the latest possible version.
* There is no upgrade path from version 1.5.3 to 1.6.1."

And after reading these and other posts about the problems with manual upgrade I've decided to stick with the old version.  It took me 3 days full time just create all the tasks and sub-tasks, and sub of sub, etc.  I need the upgrade to work without a hitch. 

I'm curious why there is an error message like this "There is no upgrade path from version 1.5.3 to 1.6.1."  in the first place?  I know what a complex task programming something like OpenGoo can be (and I'm very, very grateful it was developed and released for free: thank YOU!).   But such an error message would have to programmed wouldn't it?  and why write such a message and then announce you can upgrade to 1.6.2 as it was announced and is announced every time I log into v1.5.3?  Is this an oversight between the announcement writer and the programmers, and first you have to auto -upgrade to 1.6.1 or to 1.6.0. 

I am very happy with OpenGoo as is, and will also be grateful when the hard working team has the time to help those of us using the free version resolve this pesky upgrade issue. 

Patribus

  • Freshman
  • *
  • Posts: 41
    • View Profile
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #4 on: January 18, 2010, 02:05:28 PM »
same problem here

please: the solution!

cheers

charlyharper

  • Guest
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #5 on: January 29, 2010, 02:50:21 PM »
any news ?

charlyharper

  • Guest
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #6 on: February 02, 2010, 10:08:22 AM »
any news

enni

  • Guest
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #7 on: February 03, 2010, 07:38:52 AM »
Hello,

We use OpenGoo since several months and bravo for this very practical tool, simple and easy to use.

We tried to upgrade from 1.5.3 to 1.6.1 and we had exactly the same problem. We try the automatic upgrade and the manual too. No success. Same result.

So we add our voice to the other users to request an explanation, or better, a solution.

Thanks for all.

Regards.

Phil.

enni

  • Guest
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #8 on: February 03, 2010, 01:23:29 PM »
We just tried to upgrade to 1.6.2. Same results, same message.

Argh !

enni

  • Guest
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #9 on: February 24, 2010, 02:25:34 PM »
I've finally found the problem.
It comes from an error in the script fengoffice\public\upgrade\templates\db_migration\1_6_chivito.php at line 73

The "INSERT INTO" order needs a "VALUE" parameter which misses here.

So I, simply, deleted this line and the update works.

Best regards.

anybody2000

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #10 on: February 25, 2010, 04:39:48 PM »
Hi,
first of all, thanks for your time!
The Fix didnt work for me, in Line 73 there is no "INSERT INTO", just this:

Quote
DELETE FROM `<?php echo $table_prefix ?>report_columns` WHERE `custom_property_id` <> 0 AND `custom_property_id` NOT IN (SELECT `id` FROM `<?php echo $table_prefix ?>custom_properties`);

and deleting it dindt fix it!

regards form germany!

a2opinion

  • Full Member
  • ***
  • Posts: 177
  • Christian
    • View Profile
    • A Second Opinion
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #11 on: February 26, 2010, 03:33:16 PM »
I had a very similar issue when I upgraded from 1.5.3 to 1.6.0

I ended up creating a backup of my DB (in case something screws up) and the uploads folders.
Backup the install.
Ran the auto-update so that it would make the changes to my DB (it would then give me some kind of error or fail)
Make a backup of THAT DB.
Wipe the install and empty the DB
Install a fresh install of Feng 1.6.0
import to DB my converted backup.
replace the upload folders.

I think that's what I did, there was a lot of trial and error so steps may be getting confused or left out.  I can't tell you how many times I had restored the DB or the install when something would fail.

Once I did finally go from 1.5.3 to 1.6.0 the subsequent auto-upgrades have gone off without a hitch for the most part. (Maybe resetting permissions and killing the robots.txt file, but that's it)

matsonda

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #12 on: April 09, 2010, 05:27:37 PM »
Just wondering if there is eventually going to be a guide about how to get around this problem?  Or is their a fee that can be paid to upgrade it on my server?  I just don't want to lose everything in the upgrade process and I'm seeing by these posts 1.5.3 is still an issue.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #13 on: April 13, 2010, 12:27:58 PM »
There's not one single guide to solve all problems. It depends on the problem. It could be some incompatibility with your specific version of MySQL or PHP that we don't know about, it could be that you have done some modifications to your database that weren't expected by the upgrade script, it could be a bug in the upgrade script or it could be a permissions issue, among others. You should always perform a backup before upgrading (even better would be to try the upgrade on a copy of your installation first so that you don't risk altering your original installation, though you have to be sure that you are copying both the installation folder and database and that you are not using your old database in your new installation, so a backup here would also be recommended). If you get an error, restore your backup and try the manual upgrade. If you still get an error, your best bet is to copy the error message and post it in the forum or search the forums for a similar problem or buy support from Feng Office. If you want to get your hands dirty and your error is of the kind of "Error X at line Y" then go to the upgrade file of the current version (public/upgrade/templates/db_migration/<version><codename>.php) and delete all lines upto the one that gave an error and try again. This could work or not, depending on what line caused an error, and it is not recommended if you don't know what you are doing as it may cause upgrade problems in the future.

bukbr

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
Re: v.15.3 to v. 1.6 Failed to execute DB schema transformations
« Reply #14 on: July 27, 2015, 06:37:33 PM »
Same situation here! And still no answers!  :-\

Hi,
first of all, thanks for your time!
The Fix didnt work for me, in Line 73 there is no "INSERT INTO", just this:

Quote
DELETE FROM `<?php echo $table_prefix ?>report_columns` WHERE `custom_property_id` <> 0 AND `custom_property_id` NOT IN (SELECT `id` FROM `<?php echo $table_prefix ?>custom_properties`);

and deleting it dindt fix it!

regards form germany!

 

anything
anything