Author Topic: Upgrade to 1.6.2 results in "Error. Failed to upload file."  (Read 3666 times)

jolon

  • Newbie
  • *
  • Posts: 3
    • View Profile
Upgrade to 1.6.2 results in "Error. Failed to upload file."
« on: January 26, 2010, 03:34:59 PM »
I did an automatic upgrade from 1.6.1 to 1.6.2 last night, and am now unable to upload. Permissions are all the same as before the upgrade.

Error from log:

Session "default" started at 2010-01-26T17:31:21+0000
#1 ERROR: Error: copy() [<a href='function.copy'>function.copy</a>]: Filename cannot be empty in '~/public_html/fengoffice/application/controllers/FilesController.class.php' on line 481 (error code: 2)
Time since start: 0.037949085235596 seconds

If anyone has insight, it would be greatly appreciated!

luoshiben

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Upgrade to 1.6.2 results in "Error. Failed to upload file."
« Reply #1 on: February 23, 2010, 03:33:12 PM »
Bump. I get this same error, and it only started happening after I upgraded (automatically) to 1.6.2. I even have debug set to true in my config file, and other than the popup message (Error: Failed to upload file.) in the interface, I get no error message(s) in my /cache/log.php file. Anyone found a resolution? Thoughts? Thanks!
« Last Edit: February 23, 2010, 04:07:32 PM by luoshiben »

jolon

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Upgrade to 1.6.2 results in "Error. Failed to upload file."
« Reply #2 on: February 23, 2010, 04:57:26 PM »
Here was my problem and solution:

When I upgraded, Feng overwrote my custom php settings, which I had in the .htaccess file, not the main php.ini file for the whole server.

After restoring those settings, it was fine.

luoshiben

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Upgrade to 1.6.2 results in "Error. Failed to upload file."
« Reply #3 on: February 23, 2010, 07:20:33 PM »
Thanks for the comment and potential solution. My .htaccess file in the feng office root dir only contains:
AddDefaultCharset utf-8

My php.ini file (also in the feng office root dir) contains:
max_execution_time = 300
post_max_size = 10M
upload_max_filesize = 10M

I'm not sure what they were set to before, but I don't think any of these settings are causing the problem. (I get the failed upload error in the console no matter what size file I try to upload.) I've also verified that my cache, tmp, upload, and config dirs are writable by the apache user.

I'm also still confused as to why I'm not seeing any error messages relating to this in the log.php file. It seems that if the console is giving me an error, that error (along with more details) should be sent to the log as well. The only errors I am seeing in the log file are:

Session "default" started at 2010-02-23T18:19:54+0000
#1 ERROR: Error: Undefined variable: genid in '/.../application/views/task/task_list.php' on line 112 (error code: 8)
#2 ERROR: Error: Undefined variable: genid in '/.../application/views/task/task_list.php' on line 116 (error code: 8)

Any other thoughts? Thanks in advance.

luoshiben

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Upgrade to 1.6.2 results in "Error. Failed to upload file."
« Reply #4 on: February 23, 2010, 07:44:00 PM »
I just did some more poking around regarding the log situation and took a look at my apache error logs. It turns out that I was receiving session_start warnings (from the session_start() in the environment.php file) with a "failed: permission denied" error. Other than updating FengOffice, I have not changed anything on this server, but somehow the permissions on my php session folder were modified. Once I fixed the permission issue, my session errors went away and I can now upload files again. Still scratching my head on how this was the case, but there you have it. At least for me, the problem is solved. :) Thanks for the help.

pridedata

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Re: Upgrade to 1.6.2 results in "Error. Failed to upload file."
« Reply #5 on: March 06, 2010, 12:34:10 AM »
I get the same thing after update.

php.ini
max_execution_time = 300
post_max_size = 10M
upload_max_filesize = 10M

 

anything
anything