Author Topic: Migrated OpenGoo to New Host and Now Documents & Avatars Corrupt?  (Read 1879 times)

cscturulo

  • Newbie
  • *
  • Posts: 3
    • View Profile
I moved my Opengoo system from an old host to a new host, everything connected just fine, and the database kept all the information and users in tact, but the documents are corrupt. They show up with all the associated comments, but when you try and download and open any of the documents such as a jpg, excel doc, etc, they are corrupt and will not work. Also, none of the User Avatars came over. The Uploads folder is in tact and I uploaded it as is from the exact server it was working well on.

I am at a loss for how to remedy this. I have 20 GB's worth of files I don't want to loose.

Any ideas on how to fix this? I'm willing to hire some help if needs be.

Thanks!

kostashania

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Migrated OpenGoo to New Host and Now Documents & Avatars Corrupt?
« Reply #1 on: March 07, 2011, 09:51:20 AM »
Hi,
I think I have the same problem!
http://forums.fengoffice.com/index.php?topic=8264.0
I will inform you if I find a solution please do so If you find before me! :)
Best regards,
Kostas

kostashania

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Migrated OpenGoo to New Host and Now Documents & Avatars Corrupt?
« Reply #2 on: March 07, 2011, 10:40:43 AM »
That did not help me:
http://forums.fengoffice.com/index.php?topic=3534.0
"this method allows downloading big files without exhausting php's memory..."
but might help you ...

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: Migrated OpenGoo to New Host and Now Documents & Avatars Corrupt?
« Reply #3 on: March 14, 2011, 01:10:31 PM »
Have you both checked the permissions in those folders? And have you made sure if you have copied the right data? (the whole 'upload' folder and all its files)

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

VER

  • Freshman
  • *
  • Posts: 14
    • View Profile
Re: Migrated OpenGoo to New Host and Now Documents & Avatars Corrupt?
« Reply #4 on: September 02, 2011, 05:48:00 AM »
This may be a late response, but as I ran into the same problem, I'd thought I'd post my soluion here.

I think the problem described here is related with the way the files are copied. I downloaded the files from my old host with Filezilla, and uploaded them again. they were corrupt.
I downloaded an archive with all the files, and uploeded the archive, unzipped it at server level: problem solved.
The reason is probably (untested) that Filezilla's filetransfer mode is by default automatic, and that the files should download and upload in binary mode only.

I also ran into another problem: The FTP server at my old host truncated the number of directories, so I only saw and downloaded 498, and thought to be complete, where it were in reality 2000+ dirs. So please be aware of this possibility when migrating.

 

anything