Author Topic: [SOLVED] Error: Failed to upload  (Read 5137 times)

JedMeister

  • Newbie
  • *
  • Posts: 5
    • View Profile
[SOLVED] Error: Failed to upload
« on: May 17, 2009, 05:12:07 am »
Firstly, great product!

But I'm having a little hiccup getting it going:
I've only made one user account at this stage and was trying to upload a company logo. When I try it gives me an error. After searching I thought it best to start my own thread as no one seems to have the exact problem as me.

To ensure it wasn't my database or something else I tried to upload a zero length .jpg but still no go.

The error log says:
Code: [Select]
Session "default" started at 2009-05-17T07:06:19+0000
#1 ERROR: Error: Invalid argument supplied for foreach() in '/var/www/opengoo/application/helpers/application.php' on line 860 (error code: 2)
Time since start: 0.144171953201 seconds

This is running on a Turnkey Linux LAMP appliance http://www.turnkeylinux.org/appliances/lamp inside Virtual Box (on Win Server2k3). The only modifications I've made has been to install the 'gd' extension and share permissions on the folders noted on the OpenGoo install page.

Anyone got any ideas?

Also I had to use chmod 777 permissions (rather than 755) to get the installer to stop complaining about being able to write to the specified directories. I wonder why that is?

[edit] fixed typo

2 days later and still no one has any ideas for me!?! Oh well, can't grumble too much when its free I guess :-)

Out of interest, the Turnkey LAMP is based on Ubuntu Server (8.04.2 LTS) and includes these major components:
kernel    2.6.24-23.48
phpmyadmin    2.11.8.1-5
mysql-server    5.0.51a-3ubuntu5.4
apache2    2.2.8-1ubuntu0.3
php5    5.2.4-2ubuntu5.4
« Last Edit: May 19, 2009, 10:31:47 am by JedMeister »

JedMeister

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: [SOLVED] Error: Failed to upload
« Reply #1 on: May 19, 2009, 10:35:25 am »
Not sure quite what I did!?!?

I started again from scratch, ie reinstalled Turnkey LAMP into a clean Virtual Machine and installed OpenGoo straight on top of it. I don't know what I did different but it all worked this time!

Crazy!

Oh well, alls well that ends well.

I still have to grant 777 permissions to get OpenGoo to install but at least it works now.
 :)

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: [SOLVED] Error: Failed to upload
« Reply #2 on: May 19, 2009, 07:16:39 pm »
Hi,
Sorry for the delay in the response.
i'm glad you could solve your problem.
If you have any other problem, don't hesitate to ask.

greetings