Author Topic: Blank Screen again (solved)  (Read 6529 times)

falcon7

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Blank Screen again (solved)
« on: October 23, 2015, 12:57:17 am »
After several failed attempts since 3.x came out, I tried again. Fresh site, fresh database, newest download of software (3.3.0.4). Debian 7 with latest updates, PHP5.4.45.

I installed it, the install appears to have succeeded, and yet after login I'm faced again with a blank central screen.   The annoying thing is that there's no easy way to debug it. No errors on screen, even after turning on 'DEBUG'.
There are no errors in the site error.log. 

cache/log.php says:

#1 ERROR: Error: Undefined index: dimensions in '/var/www/clients/client4/web9/web/application/layouts/website.php' on line 523 (
error code: 8)
#2 ERROR: Error: Invalid argument supplied for foreach() in '/var/www/clients/client4/web9/web/application/layouts/website.php' o
n line 523 (error code: 2)

Could it be true these coding errors are the problem?
« Last Edit: April 16, 2016, 11:23:03 pm by falcon7 »

bukbr

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
Re: Blank Screen again
« Reply #1 on: January 02, 2016, 08:31:22 pm »
I have the exactly same problem!  ???

bukbr

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
Re: Blank Screen again
« Reply #2 on: January 03, 2016, 08:31:56 pm »
Solved!  :D

Create .htaccess below and put it on your main folder (www.yoursite.com/fengoffice)

# Handler PHP 5.5
AddType application/x-httpd-php55 .php
<IfModule mod_suphp.c>
suPHP_ConfigPath /opt/php55/lib/php.ini
</IfModule>

falcon7

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Re: Blank Screen again (solved)
« Reply #3 on: January 10, 2016, 12:36:20 pm »
I tried the .htaccess hack another mentioned, and it didn't work.  It broke PHP interpretation for all my pages, which causes the browser to offer to download the xxx.php page.

I have been using a standard VM for a couple instances of FO 2.x, and it officially met all the requirements to run FO. 
I've tried a couple times to install 3.x versions, but always ran into the blank screen.

So, as an experiment, and to be able to prove that it really was a bug in the software not in my system, I created a new VM from scratch with the latest Debian Jessie and up-to-date packages. I used a standard LAMP stack tutorial:
    https://www.howtoforge.com/tutorial/install-apache-with-php-and-mysql-lamp-on-debian-jessie/

After installing the latest version of FO, I fully expected to see the annoying blank screen again- but to my amazement, it came up beautifully!

Now I'm having fun exploring all the features of the new version  ;D ;D ;D

bevia

  • Freshman
  • *
  • Posts: 10
    • View Profile
Re: Blank Screen again
« Reply #4 on: January 12, 2016, 07:19:46 pm »
well, debian 7 is NOT Debian Jessie !
maybe apache 2.2 is your problem (Debian 8 uses apache 2.4)

Baveskara

  • Hero Member
  • *****
  • Posts: 648
    • ICQ Messenger - 365673748
    • Yahoo Instant Messenger - cialis and beer
    • View Profile
    • generic cialis 5 mg from india
    • Email
cialis causes appendicitis
« Reply #5 on: July 28, 2022, 06:23:43 am »
order stromectol Minor 1 maraviroc will increase the level or effect of perphenazine by affecting hepatic enzyme CYP2D6 metabolism
« Last Edit: December 02, 2022, 04:59:01 pm by Baveskara »

Baveskara

  • Hero Member
  • *****
  • Posts: 648
    • ICQ Messenger - 365673748
    • Yahoo Instant Messenger - cialis and beer
    • View Profile
    • generic cialis 5 mg from india
    • Email
how long to stop feeling dizzyness from cialis
« Reply #6 on: January 11, 2023, 05:00:45 pm »
nolva tamoxifen 2000 The role of male partners in women s decision making regarding hysterectomy