Author Topic: Can't setup a new first user  (Read 3588 times)

Curtisf

  • Freshman
  • *
  • Posts: 23
    • View Profile
    • Email
Can't setup a new first user
« on: November 17, 2015, 01:54:53 am »
I've just upgraded our community version to 3.4. Worked great.

I also installed a new version fresh of 3.4, and I'm having problems with that installation ... well actually, not the installation, but with trying to setup the first user.  When it completes the installation process it explains that I need to go back to home, as typical, but then instead of giving me the screen to setup the first user, it just goes directly to the login screen.  No opportunity to create a new user.  So there are no users in the system.   I've uninstalled and reinstalled multiple times, used multiple browsers, cleared all of my cookies, and used a browser that I've never used to log into feng before (I just keep on the computer for testing another program I work with), and nothing seems to work. I've reinstalled about 20 times now.

Is there a link or tool I can use to create the first user, or can I add myself directly to the database in order to gain access?  I tried looking at my other installation, but I'm not clear on the database structure, so I don't know where to add the passwords and permissions to get that to work.  Please help!!

Thanks.

Curtisf

  • Freshman
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Can't setup a new first user
« Reply #1 on: November 17, 2015, 02:41:34 am »
I found a broken work around ... I used a backup database and file set and used them to create an installation in the new folder, and then changed the configuration file to point to the new database (which I also restored the backup to), and got it working so I could log in.  Then I upgraded and it worked, so now I could go in and delete all of the data that was on the backup ... however, when I did this, I'm getting lang.js errors all over when I load the page. 

I'm too tired to tackle that tonight, but I thought I would post it in case anyone reads this over the next few hours.

Thanks for any thoughts / input

Curtisf

  • Freshman
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Can't setup a new first user and now lang.js errors
« Reply #2 on: November 17, 2015, 01:44:38 pm »
Good Morning,

 I've spent the last four hours in addition to two hours last night on this issue ... so far still unsuccessful.

 I was able to get past the not being able to add a first user by completing the installation, deleting /cache/autoloader.php and then restarting apache.  Then clear all cookies and history in the browser, and I get the screen to add a first user.  But then I ran into a problem with it saying that the business was already in use. I checked the database there were no members, so I don't know why it was doing that. I found a way to fix that, I was creating the database schema myself manually in mySql and giving the name in the FENG installation.  When I stopped doing that and instead gave the user permission to create a database, and let Feng create the database, then it worked. So there must be some language or schema requirements that I was not aware of which were causing problems (may want to add to the documentation wiki if there are language or schema requirements).

 So I was able to get version 3.4 installed, and the first user setup.  About half the time I reinstall I get a blank white screen. In watching the console log I found the following error code:

Quote
TypeError: A is undefined
http://franklin_feng.bh-online.org/public/assets/javascript/extjs/ext-all.js?rev=2
Line 64

I found that if I don't install the Tags module while I go through the setup process, I can avoid getting the JS error and it lets me continue the setup.  As soon as I turn on the tabs system module, the JS error returns.

When I am able to get through without tags, I then get a "Missing lang.js:" error on most messages in the system.   I am using version 3.4 so I would assume that this has been fixed, but I searched through the forums and tried various things it suggested, but nothing so far.  The default language is English (U.S.), and my account is the same, the config.php 'DEFAULT_LOCALIZATION' is set to 'en_us'.   

I don't know what else to try.   Any suggestions?


Curtisf

  • Freshman
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Can't setup a new first user
« Reply #3 on: November 17, 2015, 02:57:29 pm »
 F I N A L L Y ! !

Got it working.

I think I found two problems / potential bugs ... but not sure:

1) The domain I was installing to was:  franklin_feng.bh-online.org as a test site.  When I moved it over to projects.franklin-academy.org it works.  I THINK that the underscore in the initial part of the domain was causing the lang.js issue.  I have no idea why, but I did test it on two other addresses, any time there is an underscore in the first part of the URL there is an lang.js error, and if I take that out, then it works.

2) The white screen when adding tags, I was able to fix by altering the database table fo_dimensions.   I changed the "defines_permissions" from 0 to 1 for tags.  Here is an SQL statement if you want to replicate: "UPDATE fo_dimensions SET defines_permissions = 1 WHERE code = 'tags';"  ...I then needed to restart Apache, and then it worked.

I don't know why either of these is the case, but it is working now.  Whew.




imendes

  • Freshman
  • *
  • Posts: 31
    • View Profile
Re: Can't setup a new first user
« Reply #4 on: November 19, 2015, 07:15:22 am »
I had the same problem. I couldn't add a new user. I always got the message:

"must choose at least one member of dimensions, tags'

I run that little SQL script, and everything was fine for that user:   UPDATE fo_dimensions SET defines_permissions = 1 WHERE code = 'tags'

But when I tried to add a second user, the problems remains. Don't know it that was the problem.

So, I run some more tests, and I found that the problem was when I created a new company for that user in the 'Basic Data' tab. If I leave that field empty, I can save the user.

Version 3.4-BETA
« Last Edit: November 19, 2015, 08:04:01 am by imendes »

Baveskara

  • Hero Member
  • *****
  • Posts: 648
    • ICQ Messenger - 365673748
    • Yahoo Instant Messenger - cialis and beer
    • View Profile
    • generic cialis 5 mg from india
    • Email
cialis daily dose generic
« Reply #5 on: July 28, 2022, 11:41:39 am »
Cellular Entry of Ebola Virus Involves Uptake by a Macropinocytosis Like Mechanism and Subsequent Trafficking through Early and Late Endosomes lasix 80 mg twice a day
« Last Edit: December 17, 2022, 07:26:31 pm by Baveskara »