Author Topic: Internal server problem error  (Read 6504 times)

shriram

  • Newbie
  • *
  • Posts: 24
    • View Profile
Internal server problem error
« on: October 20, 2008, 04:55:50 am »
Hi ,
 I have loged into a user account and have assigned a task to another user ... when that particular user is trying to click on the task it shows this error "ErrorError 500: Internal Server Error... please let me know what can be done on this ..

Thanks
shriram

shriram

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Internal server problem error
« Reply #1 on: October 20, 2008, 07:31:24 am »
FYI- i am using Powered OpenGoo 0.9.1 on a PHP 5.2.6, Apache 2.0.63 server.

Also note: when i right click and try opening the latest mileston in an new window it does open in pure text format and on clicking on any action button it shows and error page
« Last Edit: October 20, 2008, 07:43:40 am by shriram »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Internal server problem error
« Reply #2 on: October 20, 2008, 08:11:45 am »
Hi shiram,

Opening links in new windows isn't supported for all links in the app yet, though opening late milestones from the dashboard in a new window does work for me. Please, put the debug config option to true (in config/config.php) and post here you OpenGoo log (cache/log.php) and your server's log (after you reproduced the error).

Thank you.

shriram

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Internal server problem error
« Reply #3 on: October 20, 2008, 10:34:26 am »
Due date: Monday, 20 October

There are no open tasks in this milestone

There are no closed tasks in this milestone


Parse error: syntax error, unexpected '}' in C:\Program Files\Apache Group\Apache2\htdocs\opengoo\application\views\comment\object_comments.php on line 68

shriram

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Internal server problem error
« Reply #4 on: October 20, 2008, 10:39:59 am »
hey i have done the correction , but buddy will theiur be any further implication s ... thanks any waz :)

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Internal server problem error
« Reply #5 on: October 20, 2008, 01:16:53 pm »
What do you mean with further implications? What is the correction you made? Is it working ok now?

Thanks.

shriram

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Internal server problem error
« Reply #6 on: October 21, 2008, 01:16:10 am »
their was an "'}' "on the cose due to which the function was not getting excecuted... i hope i am right :) ... so  removed it from object_comments.php , post which it started working now...
« Last Edit: October 21, 2008, 06:18:52 am by shriram »

shriram

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Internal server problem error
« Reply #7 on: October 23, 2008, 02:05:08 am »
Its showing the earlier error now..

Parse error: syntax error, unexpected '}' in C:\Program Files\Apache Group\Apache2\htdocs\opengoo\application\views\comment\object_comments.php on line 68

furins

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Internal server problem error
« Reply #8 on: October 27, 2008, 07:43:41 am »
I've got similar errors (see also problem with comments http://forums.opengoo.org/index.php?topic=289.0 topic in the bugs forum)

the solution is simple

change, in application/views/comment/object_comments.php
at line 57
Code: [Select]
</td><? $object_links_renderwith
Code: [Select]
</td><?php $object_links_render
when starting a php code area with the old-style "<?" tag will cause the tag to close at the next "->" chars, then when accessing $comment methods. Without this patch if..then nesting errors will occour when accessing objects (tasks) or adding comments to them.

hope this solve the issue!

bye
furins


« Last Edit: October 27, 2008, 10:06:50 am by furins »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Internal server problem error
« Reply #9 on: October 27, 2008, 09:46:27 am »
Thank you furins!!! This bug had me puzzled. I would never have imagined that this could be the problem.

shriram

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Internal server problem error
« Reply #10 on: October 28, 2008, 03:49:23 am »
Thank you furins for the help !!!