Author Topic: How to stop "Task modified Emails"  (Read 8452 times)

ranganayaki

  • Newbie
  • *
  • Posts: 8
    • View Profile
How to stop "Task modified Emails"
« on: May 25, 2009, 08:21:14 pm »
I am currently running v1.4 . How do I stop "task has been modified" emails? I currently don't have any use for them.

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: How to stop "Task modified Emails"
« Reply #1 on: May 26, 2009, 09:45:17 am »
In User account -> edit preferences -> Task Options there is the option to uncheck by default the "Send email notification" checkbox.
The option is "Task notification is checked by default". Set it to 'No' to disable notifications by default.

ranganayaki

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: How to stop "Task modified Emails"
« Reply #2 on: May 26, 2009, 09:47:12 am »
I assume unchecking the box will disable the notification for all task assigned, new comments etc. Am i right?

ranganayaki

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: How to stop "Task modified Emails"
« Reply #3 on: May 26, 2009, 09:49:13 am »
I would like to stop only these Tasks Modified Emails.

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: How to stop "Task modified Emails"
« Reply #4 on: May 26, 2009, 10:54:45 am »
Disabling that option, the only thing that changes is that the checkbox to send notifications when adding or modifiying a task will not be checked by default and if not checked the assigned user(s) will not receive an email.

Sorry, i misunderstood your question, the correct answer is that in this version there is no way to disable that kind of notifications.
This notifications are sent to all subscribers.

cheers

ranganayaki

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: How to stop "Task modified Emails"
« Reply #5 on: May 26, 2009, 10:58:50 am »
sorry to bother you again...could you please let me know where I can find the template for this "task modified" email? I would like to change the content of the email at the very least

Thanks in advance

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: How to stop "Task modified Emails"
« Reply #6 on: May 27, 2009, 10:25:50 am »
That template is not only for tasks, is for every object that is added, modified or deleted.
By modifying it, the other emails will be modified too.
The template is 'application/views/notifier/general.php' and its values are set in the Notifier class, in method 'objectNotification(...)

mani

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: How to stop "Task modified Emails"
« Reply #7 on: June 17, 2009, 02:10:57 am »
In User account -> edit preferences -> Task Options there is the option to uncheck by default the "Send email notification" checkbox.
The option is "Task notification is checked by default". Set it to 'No' to disable notifications by default.

Hi!

Sorry for my question, but I cannot find any option in user account to uncheck this preference. I would like to disable sending any mail notifications.

Please, can you tell me, where I can find this option?

Thanks a lot.

Nice greetings, mani

mani

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: How to stop "Task modified Emails"
« Reply #8 on: June 20, 2009, 01:23:08 am »
Sorry, but can anybody help please?

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: How to stop "Task modified Emails"
« Reply #9 on: June 29, 2009, 02:16:54 pm »
It is exactly where Alvarotm01 says, on my screen I go to Account, Edit Preferences, Task Options and there it is.
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

fernandog

  • Jr. Member
  • **
  • Posts: 66
    • View Profile
Re: How to stop "Task modified Emails"
« Reply #10 on: June 24, 2010, 01:54:40 pm »
I know this is an old topic, but I had the same question and just figured it out.

From application/models/notifier/Notifier.class.php, delete the following:

Code: [Select]
} else if ($action == ApplicationLogs::ACTION_EDIT) {
self::objectNotification($object, $subscribers, logged_user(), 'modified');

This will stop "object has been modified" emails