Author Topic: Cannot add initial adminstrative user/company  (Read 4198 times)

porkens

  • Newbie
  • *
  • Posts: 2
    • View Profile
Cannot add initial adminstrative user/company
« on: November 18, 2008, 07:35:13 pm »
Hello,
I've managed to get OpenGoo successfully installed (at least, it tells me it's successfully installed, and I can see all of the tables that were created in the database). However, when I click the link on the "Step 4: Finish" page to create the initial administrative user, I am presented with a blank page. I turned on debugging, and tried loading the main page again. This is the error that spit out in the log:

Code: [Select]
<?php die(); ?>
Session "default" started at 2008-11-18T22:36:39+0000
#1 FATAL: exception 'OwnerCompanyDnxError' with message 'Owner company is not defined' in /opt/lampp/htdocs/cln/opengoo/application/models/CompanyWebsite.class.php:64
    Stack trace:
    #0 /opt/lampp/htdocs/cln/opengoo/application/models/CompanyWebsite.class.php(45): CompanyWebsite->initCompany()
    #1 /opt/lampp/htdocs/cln/opengoo/application/models/CompanyWebsite.class.php(49): CompanyWebsite->init()
    #2 /opt/lampp/htdocs/cln/opengoo/application/application.php(21): CompanyWebsite::init()
    #3 /opt/lampp/htdocs/cln/opengoo/init.php(140): require_once('/opt/lampp/htdo...')
    #4 /opt/lampp/htdocs/cln/opengoo/index.php(9): require('/opt/lampp/htdo...')
    #5 {main}
Time since start: 0.0179419517517 seconds
-------------------------------------------------------------------------------

I don't have an owner company defined yet, as this is what I'm trying to do when this error occurs. Can anyone help me?

This install is running under a LAMPP install on a SUSE 9 server. I've checked the LAMPP error log, and it is showing no issues.
« Last Edit: November 18, 2008, 07:40:50 pm by porkens »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Cannot add initial adminstrative user/company
« Reply #1 on: November 19, 2008, 02:06:28 pm »
The problem probably is another one, that didn't allow the install process to finish correctly, and so the owner company wasn't created. This error must have came afterwards when trying to access the installation with no owner company.

Not really sure of what it could be. Does you MySQL have InnoDB enabled? Maybe you can try creating the owner company and the administrator manually on the DB but I don't know how far would this take you.

porkens

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Cannot add initial adminstrative user/company
« Reply #2 on: November 19, 2008, 02:49:50 pm »
Hi ignacio,
Thank you for the reply. Before I read it I actually did what you suggested, and got things working. In the database, I manually added a company (with id 1, to table companies), added a user assigned to that company (with id 1, to table users), added an Administrator group (with id 10000000, to table groups), and added my user to that group (in table group_users).

I tried using id 1 for the Administrator group, but it didn't work -- when I logged in, my user had no administrative rights (no link to Administration). I tried 10000000, and that worked. Haven't tried any other values, so I'm not sure if any others would work.

I had to click the "forgot password" link on the login page initially, as I had no idea what my password was set to in the database (as it is encrypted). I got an e-mail with the reset password, and I was good to go.

Hope this might help anyone else with issues.

aplima

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Cannot add initial adminstrative user/company
« Reply #3 on: February 18, 2009, 03:25:41 pm »
I'm facing the same problem...
My error is diferent thought...

Query failed with message 'You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1'

Tried innodb and myisam with same error.
Even tried to manually add the user, the group, etc as porkens sugested without success.

I'm clueless now. Must be something really simple, that will make me feel really stupid.
I would appreciate any help.

Best regards,

António Lima

PS: Pardon any errors on my english, please...

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Cannot add initial adminstrative user/company
« Reply #4 on: February 18, 2009, 04:40:32 pm »
Hi aplima,

This error was on the 1.2 zip but was corrected in the 1.2.0.1 zip. You need to change 'coulmns' to 'columns' on file 'application/models/searchable_objects/SearchableObjects.class.php' line 250.

aplima

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Cannot add initial adminstrative user/company
« Reply #5 on: February 18, 2009, 08:53:51 pm »
Quite simple as I suspected...
Thanks a lot...

It works. Time to explore.

Keep up the great work.

Cheers