Author Topic: [1.0] Adminstrator user do not have Administration access?  (Read 3494 times)

lawrence

  • Newbie
  • *
  • Posts: 4
    • View Profile
[1.0] Adminstrator user do not have Administration access?
« on: November 22, 2008, 06:27:08 pm »
Bug description: Adminstrator user do not have Administration access?

How to reproduce:

1. When Administration link was clicked, a error message is show. Doesn´t matter what workspace is selected. The "admin" user is the user i created when i install the OpenGoo.
2. Happend after i create some workspaces. Follow attached screenshot.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [1.0] Adminstrator user do not have Administration access?
« Reply #1 on: November 22, 2008, 08:17:03 pm »
Thanks for your report. We'll look at it.

Arthur Mullard

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
Re: [1.0] Adminstrator user do not have Administration access?
« Reply #2 on: December 18, 2008, 04:50:56 pm »
Using 1.1

I have the same problem. Only the owner can access the adminstration panel - ALL other adminstrators have no access getting the same error as above.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [1.0] Adminstrator user do not have Administration access?
« Reply #3 on: December 21, 2008, 11:05:49 am »
Strange. We don't have that problem. There must be something in there that the admin users you defined can't access. We'll look at it.

Arthur Mullard

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
Re: [1.0] Adminstrator user do not have Administration access?
« Reply #4 on: January 06, 2009, 06:22:50 am »
Ah! Those without access were not assigned to the owner company. When we assigned them to the owner company access returned.
So, I guess an improvement would be to either:
- not allow people non-owner company users to be assigned admin status in the first place
- make sure non-owner company users can access admin once assigned admin status

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [1.0] Adminstrator user do not have Administration access?
« Reply #5 on: January 06, 2009, 09:49:50 am »
Great! Thanks for the suggestions.