Author Topic: Custom properties on links  (Read 4278 times)

maever

  • Newbie
  • *
  • Posts: 7
    • View Profile
Custom properties on links
« on: January 27, 2009, 04:32:15 pm »
I have noticed that custom properties on weblinks do save but don't load on the latest 1.2beta.

(Using Internet Explorer 7)
It displays a JS error upon loading:

Code: [Select]
Statement on line 3: Type mismatch (usually non-object value supplied where object required)
Backtrace: Line 3 of eval script var count = parent.getElementsByTagName("tr").length - 1;
Line 41 of eval script og.addCustomProperty(parent, "user", "info+sagramore.com");
og.addCustomProperty(parent, "pass", "xxxxxx"); ...
Line 684 of linked script http://xxx.xxxx.nl/public/assets/javascript/og/og.js window.eval(match[2]); ...
Line 10 of linked script http://xxx.xxx.nl/public/assets/javascript/extjs/adapter/ext/ext-base.js
function(){if(this.locked){return false}
this.locked=true;var R=!F;if(!R){R=(I>0)}var Q=[];for(var M=0,L=H.length;MClick to remove


Also,
I may add,
an option to easily access/view these custom properites is missing.
I use them to store login information to certain sites, there seems no other way to view them then to edit them.

« Last Edit: January 29, 2009, 03:20:20 pm by ignacio »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Custom properties on links
« Reply #1 on: January 29, 2009, 03:08:42 pm »
For other object types you can see custom properties on the Properties panel (bottom right). The problem with weblinks is that it has no view like the other objects, which shall be corrected very soon.

Thanks.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Custom properties on links
« Reply #2 on: January 29, 2009, 03:18:43 pm »
Does this happen to you with all weblinks and custom properties? At what point does the error show? I was able to add and edit custom properties on IE7 with no problems.

maever

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Custom properties on links
« Reply #3 on: January 30, 2009, 04:41:03 pm »
I have to confirm that I am also unable to reproduce this bug now in IE7.
However it will generate this error in "opera 9.65".

now you certainly should not have to specifcally support this browser because of my unwillingness to use a normal one.
But this browser has worked with all major features so far, it would not be much of challange to get this working, its probably jut  a wrong declared.

also on a sidenote,
The custom property fields do not reappear upon editing them in IE7 once you saved them.


here is the error I got from your demo version.
Code: [Select]
Statement on line 3: Type mismatch (usually non-object value supplied where object required)
Backtrace: Line 3 of eval script var count = parent.getElementsByTagName("tr").length - 1;
Line 41 of eval script og.addCustomProperty(parent, "tralala", "tralala");
og.addCustomProperty(parent, "tadaaaddaaaa", "i5463786834");
Line 1082 of linked script http://demo.opengoo.org/en_us/public/tools/combine.php?...


Thank you for your time!
« Last Edit: February 04, 2009, 11:31:17 am by ignacio »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Custom properties on links
« Reply #4 on: February 04, 2009, 11:50:50 am »
Fixed for 1.2 RC2. Thanks.