Author Topic: missing lang.js  (Read 9114 times)

thibautds

  • Newbie
  • *
  • Posts: 6
    • View Profile
missing lang.js
« on: February 15, 2009, 09:34:37 am »
Hey i've installed opengoo 1.1 and when i'm logged in I see everywhere missing lang.js please help me.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: missing lang.js
« Reply #1 on: February 15, 2009, 12:39:38 pm »
What language are you using? What browser? What do you see if you browse to <your opengoo>/index.php?c=access&a=get_javascript_translation?

thibautds

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: missing lang.js
« Reply #2 on: February 15, 2009, 02:29:00 pm »
it says in a box at the top of the page:

missing lang.js: error
o.g.ContentPanel is not a contructor

and a second box says:

missing lang.js: error
illegal character

I speak dutch and I use mozilla firefox 3.X and at the top of the page I see http://thibaut.comze.com/opengoo/
If you want login my user is admin and pass is aqwzsxedc
But I think you also must know that I'm using a free host www.00webhost.com

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: missing lang.js
« Reply #3 on: February 15, 2009, 04:22:37 pm »
Hi, your webhosting is appending some code to the javascript translation files, as well as to every ajax request. That is what is breaking OpenGoo.
Code: [Select]
<!-- www.000webhost.com Analytics Code -->
<script type="text/javascript" src="http://analytics.hosting24.com/count.php"></script>
<noscript><a href="http://www.hosting24.com/"><img src="http://analytics.hosting24.com/count.php" alt="web hosting" /></a></noscript>
<!-- End Of Code -->
You could try searching a free PHP hosting server that doesn't do that, or get a paid hosting, or avoid all problems and get support by buying an installation at http://www.fengoffice.com .

Thanks.

thibautds

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: missing lang.js
« Reply #4 on: February 15, 2009, 05:47:38 pm »
thanks for information

jack h

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: missing lang.js
« Reply #5 on: March 03, 2009, 05:37:15 pm »
Hi,

I had a problem too with the missing lang.js error.

As far as I can tell, theres a problem with URLs, son the lang.js files can´t be reached.

my solution was to copy the languages folder to the public/assets/javascript, and it worked.

This happend with Open Goo 1.3 beta

regards

Jack H

cale250

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: missing lang.js
« Reply #6 on: March 07, 2009, 12:17:45 pm »
000webhost has a way to remove that silly tracking code from all the pages on your website- mentioned on the EyeOS website as it breaks that package as well-

Go to http://members.000webhost.com/analytics.php and enter your username and password, and make sure you click "Disable" in the combo box. It solved a long string of issues with my web apps. However, I would recommend installing the newer 1.3 RC1 to get improved MySQL integration (as 000webhost uses the MyISAM engine).

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
Re: missing lang.js
« Reply #7 on: July 05, 2009, 05:41:08 pm »
Hi,

I had a problem too with the missing lang.js error.

As far as I can tell, theres a problem with URLs, son the lang.js files can´t be reached.

my solution was to copy the languages folder to the public/assets/javascript, and it worked.

This happend with Open Goo 1.3 beta

regards

Jack H

The issue does not seem be closed so, I inform that on today installation of 1.2.0.1 has happened the same and I've applied this same solution.

I'm doing this install for install from there v1.5.
« Last Edit: July 05, 2009, 05:59:17 pm by fcoauga »
-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

cobbler

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: missing lang.js
« Reply #8 on: July 10, 2009, 06:11:16 pm »
Installed Opengoo 1.4.2 on a local mac running OS X 10.4.11, MySQL 4.1.12 , innodb, php5
Everything works, except am also seeing Missing lang.js:  in front of various menu items.
Was able to switch to different languages under Account General localization from en_us
and the body text changes to the appropriate language
but the menu items still have Missing lang.js
So it is somewhat cosmetic, but would be nicer if someone could point me in the right direction to fix it.

Tried copying the language directory into assets as suggested in the thread...no luck.
About the only other place I can think of is that the MySQL database says collation is utf8_unicode_ci
for the opengoo database tables. 



cobbler

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: missing lang.js
« Reply #9 on: July 13, 2009, 06:05:42 pm »
For what it's worth,
was able to figure out that the 
Missing lang.js:   text

is coming from public/assets/javascript/app.js

Now to figure out if there is some finickiness about how setlocale is handled on the mac.

cobbler

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: missing lang.js
« Reply #10 on: July 16, 2009, 12:52:01 am »
localization to other languages for the most part works,

creating a file on the webserver called locale.php
<?php
echo setlocale(LC_ALL,NULL);
?>
and visiting it with a web browser
returns
C

issuing
locale
from the unix command line returns the following
LANG=
LC_COLLATE="C"
LC_CTYPE="C"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL="C"

created a C.php and C directory by copying the en_us.php and en_us/
in /languages, and that shows up properly as a possible localization choice through the Account settings. but still get Missing lang.js on the top menu items.


Gave up and replaced
                return "Missing lang.js: " + name;
with
                return "" + name;

Sorry folks, I'm just not clued enough to do this properly.

For what it's worth,
was able to figure out that the 
Missing lang.js:   text

is coming from public/assets/javascript/app.js

Now to figure out if there is some finickiness about how setlocale is handled on the mac.


fredr

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: missing lang.js
« Reply #11 on: July 22, 2009, 09:10:07 pm »
In case it helps anyone else that might have made the same mistake...

After an initial install of 1.5C, I had the "missing lang.js" problem all over the page.  After some debugging, I discovered that when I set up my virtual host I had set the document root to the .../opengoo/public directory, which then causes opengoo to look for lang.js in .../public/language/... which is not correct.  After changing the vhost document root to just .../opengoo, everything still works and the lang.js is found

greg2b

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: missing lang.js
« Reply #12 on: October 10, 2009, 03:24:36 pm »
I just had the same error using 1.5.3 on chrome/firefox/IE. Originally I got the error below. then it said i was missng lang.js every where. This was after installation but this is where i found the bug. If this post need to be in another topic I'm sorry.

I fixed it by using the suggestion of copying the language file to the public assets folder. Everything seems to be ok, but
some users who have uploaded file while this was happening did not have this issue and I can not see there files that they uploaded.
I can not a problem any more.

Any suggestions

Thanks
-------------
Error (DirDnxError)
Directory '/homepages/36/d143445164/htdocs/sportszone/language/DefauPr' doesn't exists
Error params:
File: /homepages/36/d143445164/htdocs/sportszone/environment/classes/localization/Localization.class.php  
Line: 191  
Dir path: /homepages/36/d143445164/htdocs/sportszone/language/DefauPr  
Backtrace:
#0 /homepages/36/d143445164/htdocs/sportszone/environment/classes/localization/Localization.class.php(126): Localization->loadLanguageSettings()
#1 /homepages/36/d143445164/htdocs/sportszone/application/application.php(31): Localization->loadSettings('DefauPr', '/homepages/36/d...')
#2 /homepages/36/d143445164/htdocs/sportszone/init.php(138): require_once('/homepages/36/d...')
#3 /homepages/36/d143445164/htdocs/sportszone/index.php(9): require('/homepages/36/d...')
#4 {main}
Autoglobal varibles:
$_GET: Array (
  ['c'] => (string) 'access'
  ['a'] => (string) 'index'
)  
$_POST:  
$_COOKIE: Array (
  ['PHPSESSID'] => (string) '356338d64b43caf6888d0c0037808284'
  ['id'] => (string) '1'
  ['token'] => (string) '5b1a84f41dfe6f666deeb0a6083c17397de68d1f'
  ['remember'] => (string) '1'
)  
$_SESSION:  
Execution time:
Total execution time: 0.723290 seconds
--------------



« Last Edit: October 10, 2009, 03:39:23 pm by greg2b »